Datahub
数据改变生活

1171: Sum Kind of Problem

发表时间:2022-10-27 19:24

1171: Sum Kind of Problem

时间限制: 1 Sec   内存限制: 128 MB

题目描述

For this problem you will compute various running sums of values for positive integers.

输入

The first line of input contains a single integer P, (1 ≤ P≤ 10000), which is the number of data sets
that follow.   Each data set should be processed identically and independently.

Each data set consists of a single line of input.   It contains the data set number, K, followed by an
integer N, (1≤ N ≤ 10000).   

输出

For each data set there is one line of output.   The single output line consists of the data set number,
K, followed by a single space followed by three space separated integers S1, S2 and S3 such that:

S1 = The sum of the first N positive integers.
S2 = The sum of the first N odd integers.
S3 = The sum of the first N even integers.

样例输入 Copy

3

1 1

2 10

3 1001

样例输出 Copy

1 1 1 2

2 55 100 110

3 501501 1002001 1003002

#include<bits/stdc++.h>

using namespace std;

int main(){

int t;

scanf("%d",&t);

while(t--){

int n,k;

scanf("%d%d",&k,&n);

long long ans1=1LL*n*(n+1)/2;

long long ans2=1LL*n*n;

long long ans3=1LL*n*(2+2*n)/2;

printf("%d %lld %lld %lld\n",k,ans1,ans2,ans3);

}

return 0;

}


文章分类: 算法例题
分享到:
QQ:258506508                                     联系电话:020-000000    000-000000                                   联系邮箱:xxx@.co.m                                     联系地址:XXX省XXX市XXX县XXX路